Yealink Redirector asking for username and password
Problem
When you are attempting to connect a Yealink handset to your hosted PBX service you encounter a prompt asking for a Username & Password.
This may happen when you connect a new handset, or, when you have reset a handset that was already connected.
Cause
This is caused when the handset has successfully been pointed to the hosted PBX server, however, the PBX has not been set to allow temporary unauthenticated connections.
Resolution
There are two methods for resolution:
Method 1 (Easiest):
Allow MAC based (Unauthenticated) requests temporarily.
- Log into your hosted PBX service as an administrator
- Navigate to Accounts > Extensions
- Select the extensions that the handsets are assigned to
- From the dropdown box at the bottom of the table, select Open accounts for MAC-based provisioning

- Click the check mark next to the dropdown box, a timer will display next to the extension in the Status column.
- Reboot the handsets and they will now connect
Method 2:
Manually enter the Username and Password for the handset.
- Log into your hosted PBX service as an administrator
- Navigate to Advanced > VoIP Phones
- Click the
icon next to the MAC address of the handset you need to connect
- The password will display momintarily on the screen
The username for the handset is the MAC as it appears in the list. Use this and the password that we just revealed to authenticate the handset to the server.
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